منوهای نصب در پنل مدیریت

سازگاری برنامه های آندروید با نسخه های قبلی

سیستم عامل آندروید روز به روز در حال گسترش است و شاهد پیشرفت سریع این سیستم عامل هستیم؟حال به عنوان برنامه نویس چه کنیم ؟آیا قید مشتریانی که از نسخه های قبلی آندروید استفاده میکنند را بزنیم؟آیا قید ویژگی های جدید این سیستم عامل را بزنیم؟
در ادامه آموزش های Android Xamarin  با ما همراه باشید تا این مشکل را به بهترین راه حل کنیم.

 

بهترین راه حل این است که بیایم بگوییم اگر نسخه سیستم عامل مشتری از نسخه مورد نظر ما پایین تر بود فلان فیچر را غیر فعال کن یا از حالت جایگزینش استفاده کن.در نمونه کد زیر نحوه پیاده سازی را میبینیم:

 

if (Android.OS.Build.Version.SdkInt >= Android.OS.BuildVersionCodes.Lollipop) 
{
    // Do things the Lollipop way
}
else
{
    // Do things the pre-Lollipop way
}

 

 

منبع : https://developer.xamarin.com/guides/android/application_fundamentals/understanding_android_api_levels

0 پاسخ در "سازگاری برنامه های آندروید با نسخه های قبلی"

ارسال یک پیغام

نشانی ایمیل شما منتشر نخواهد شد. بخش‌های موردنیاز علامت‌گذاری شده‌اند *

2017 © تمامي حقوق مطالب سايت Developersian محفوظ و همچنین استفاده از مطالب سایت با ذکر منبع بلامانع است.
X